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SSpot Users Guide 
SCI-US-REP-SW08-2018 

Version 2.6.0 

1. INTRODUCTION 

Welcome to SOFIA Spot (SSpot) – the tool for phase II SOFIA observation planning. The SSpot 
software is available for download from the SOFIA DCS website: 
 
 http://dcs.sofia.usra.edu 
 
SSpot is based on Spot-common, a framework that was used to develop the Spitzer Spot and 
Herschel Spot software, and so has a similar look and feel to these other versions of Spot.  Since 
SOFIA is an airborne observatory and not a satellite, some parameters and concepts found in 
these other versions of Spot are not applicable.  
 
SSpot is intended for use primarily by the SOFIA observing community (general investigators, 
GIs) to plan their observations. The GIs will use SSpot to specify the values of the parameters 
relevant to their proposed observations with each SOFIA instrument and visualize the proposed 
observations on an image of the target field. The set of parameters for any given observing mode 
and instrument configuration comprise an Astronomical Observing Template (AOT); the 
completed template with the specified values is known as an Astronomical Observation Request 
(AOR). 

2. SUPPORTED AOTS 

SSpot supports the following AOTs: 
 FORCAST: 
  IMAGING 
  GRISM 
  GRISM_XD (Not available in Cycle 4) 
 GREAT: 
  Single_Point (PSW | BSW) 
  Raster_Mapping (RASTERMAP_PSW| RASTERMAP_BSW) 
  OTF_Mapping (OTFMAP_PSW| OTFMAP_BSW) 
 FLITECAM: 
  IMAGING 
  GRISM 
 EXES: 
  HIGH_MED 
  MEDIUM 
  HIGH_LOW 
  LOW 
 FIFI-LS: 
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  SYMMETRIC_CHOP 
  ASYMMETRIC_CHOP 
  BRIGHT_OBJECT 
  SPECTRAL_SCAN 
 HAWC_PLUS: (new in Cycle 4) 
  CHOP_NOD (TOTAL_INTENSITY, C2N) 
  CHOP_SCAN(TOTAL_INTENSITY, OTFMAP) 
  POL_NOD (PLLARIZATION, C2N 
 FPI_PLUS: (new in Cycle 4) 
  IMAGING 
   
 

3. KNOWN ISSUES  

• SSpot currently does not support overlays for orbital elements.  This will be added in a 
future release. 

• Note that because SOFIA is an airborne observatory and not a satellite or ground-based 
observatory, some AOT parameters cannot be specified until the AOR is flight planned. 

4. DOWNLOAD AND INSTALL 

1. Navigate to http://dcs.sofia.usra.edu/ and click on “Download” for the appropriate 
platform. 

 
2. Decide which version of SSpot to download.  Due to the incompatible setting of certain 

parameters for a given instrument between cycles, you need to download the correct 
version of SSpot in order to edit the AORs for a given cycle.  For example, if you are 
editing Cycle 4 AORs, download the Cycle 4 SSpot. If you need to edit the cycle 3 
AORs, download the Cycle 3 SSpot. This is due to the nature of the SOFIA instruments 
being upgraded between cycles. For example, certain filters in the previous cycles are 
replaced with new filters in the future cycles. 

 
3. Install SSpot: 

◦ For Mac, double click the downloaded disk image (.dmg) and drag the “sspot” 
folder to your local hard drive (usually the Applications folder); If you are 
running Moutain Lion (OS X 10.8) and up, and receive "file damaged" error 
during the installation, it does not mean that the dmg file is damaged. You just 
need to lower the security settings temporally to install SSpot. After that, return 
your security settings back to normal. Here is what you do: Launch System 
Prefrefence -> Security and Privacy -> General, and select Allow applications 
downloaded from Anywhere. Return the security setting to normal afterwards. 

◦ For Windows, double click the downloaded installer (.exe) and follow the 
instructions; 

◦ For Linux, in the install directory, type “chmod +x sspot_1_2_0.sh” and hit 
return. Then type the command “./sspot_1_2_0.sh” . 
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5. QUICK START 

 For quick start, refer to the SSpot_pocket_guide.pdf that is packaged with the installer. 

6. RUNNING SSPOT 

6.1. SSpot Main Screen 

SSpot uses several icons as shorthand for commonly used functions that are also available under 
the Menus.  They are shown in the following figure.   
 

 
 
Figure: The menus and icon bar on the SSpot  main screen provide access to the various 
functions within Spot. 
 
From left to right the icons are: 
 

  read in AORs/targets from a file  

  save AORs/targets to a file  

  undo last action 
 
The next three AOR icons become active once you have defined AORs: 

  delete the current AOR  

  modify the current AOR  

  make a copy of the current AOR  
 
The four bull’s-eye icons are for manipulating targets:  

  new target  

  delete target  

  modify target  

  show the current target list  
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6.2. Creating New AORs without a Proposal or an Observing Plan 

To create a new AOR, use the menu Observation->[Instrument].  SSpot will create an AOR 
populated with default values defined in the AOT.  You can edit and visualize the AORs, then 
save them to a local disk.  Since the AORs don’t have a valid proposal ID associated with them, 
SSpot will not upload them to the SOFIA DCS database at the SSC.   
 

6.3. Creating AORs from an Observing Plan 

You can also create AORs from an existing observing plan in the SOFIA Data Cycle System.  If 
you already have a saved .aor file that was created from the proposal you submitted and has a 
valid proposal ID, you can work on it by opening the file from SSpot. You only need to log in to 
the DCS when you want to upload these AORs to the DCS server. 
 
To start, search for your obsplan with the obsplan ID that you received when you submitted your 
proposal. The Obsplan ID is the same as your proposal ID. Open the ObsPlan Chooser using 
“File->Download AORs from DCS…” The quickest way is to enter your ObsPlan ID (also 
known as proposal ID, program ID) in the lower left “Get Obs Plan” panel’s ObsPlanID input 
field and press the “Get Plan” button. You will be prompted to log in to your dcs account in 
order to search your observing plan. The login email and password are the ones you registered 
with DCS. You have permission to see the details of only your own proposal; you will get a 
“Permission Denied” message if you enter a proposal ID that is not yours.  
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Open the tree on the right side of the chooser panel to see the details of the plan, click on the top-
most node labeled "Proposal", then click on the "Accept" button.  (The “Accept” button will only 
be enabled after you click on the “Proposal” node.) 
 

 
 
 
If this is the first time you are accessing your observing plan, or if you have not previously 
uploaded any AORs from SSpot, you will receive a message indicating that there are no AORs 
associated with the obsplan and confirming that you would like to create new AORs.  Upon 
clicking “yes” a set of AORs will be created from your obsplan and displayed in the summary 
table. 
 
After you have saved your AORs and uploaded them successfully to the DCS obsplan database, 
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subsequent uses of the chooser will retrieve this set of AORs and automatically populate the 
AORs summary table.  
 
 

 
 

6.4. Estimated Total Time  

You may notice that the “Estimated” time and “Awarded” time in the status bar in the main 
window do not match.  The overhead for each AOR is recalculated using the extra information 
you fill out in the AOR editor window during phase 2, so it is more accurate. You are not 
required to make the estimated time under the awarded time in order to submit the AORs. You 
can contact your support scientists if you have questions. 

6.5. Customize the columns in the Summary Table 

You can show and hide any columns in the AORs Summary Table by clicking on the icon above 
the scroll bar in the table’s header, indicated by the red circle in the figure above.  You selections 
will be saved as part of your preferences.  To see all columns, simply click on the icon and select 
“Reset Table to Factory Setting”. 
You can rearrange the columns by dragging the column header around. 
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You can also sort the table columns. 

6.6. Adding New AORs 

You can add new AORs to the list of AORs created from your proposal with the “Observation-
>[Instrument]” menu. SSpot creates an AOR populated with default values defined in the AOT. 
Alternatively, you can select an AOR from the list, and duplicate it using the Copy AOR 
function. You can also create a large number of new AORs by using the AOR replication tool in 
the “Tools” menu. The newly created AORs will be assigned unique IDs when you save this set 
and upload them to the DCS server. 
 

6.7. Editing AORs 

You can work on only one AORs at a time.  (To work on a different AOR, you must close the 
one you are currently working on.)  Double clicking on an AOR, will bring up an AOR editor 
window appears. You can edit the filters, nod type, and exposure time and any the fields that are 
available and editable (not grayed out). After editing, click on the OK button for your changes to 
take effect.  If you want to work on a set of AORs from a different *.aor file saved on a local 
disk or downloaded from the DCS database, you need to clear the current AOR summary table 
using the “Edit->delete All AORs” option first, then load the new set of AORs into SSpot using 
the “File->Open” or “File->Download AORs from DCS” options. 
Only AORs that have a state of “new” or “problem” can be modified. AORs that are “done”, 
“pending”, or “approved” cannot be modified or deleted.  However, SSpot will allow you to 
open them in the detailed AOR dialog, view them, change values, and visualize them. However, 
SSpot will not allow you to upload any modifications to the DCS database, and will simply 
discard any changes when you close the editing window.  In other words, you can change the 
values and view them, but these changes will not be saved.  Note that you can also duplicate an 
AOR that is not editable; the duplicated AORs will be in a “new” state thus is fully editable. 
 



SCI-US-REP-SW08-2018 
revision D 

VERIFY THAT THIS IS THE CORRECT REVISION BEFORE USE 
8  

 



SCI-US-REP-SW08-2018 
revision D 

VERIFY THAT THIS IS THE CORRECT REVISION BEFORE USE 
9  

 
 
Edit Targets:  You must use the TargetList to add/modify/delete a target.  To open the 
TargetList editor, you can use the menu “Targets->Target List” or click on the “Target List” 
button in the AOR editor window. 
 
Starting Cycle 4, SSpot automatically adds Guide Stars to each AOR whenever a new target is 
created or an existing target is modified. The GIs do not need to worry about the Guide Stars, 
they are for the SOFIA telescope operators to set up the telescope during operation. 
 
Edit Dither Positions:  The dither control panel is opened via the “set dither pattern” button.  A 
list of offset positions will be automatically generated according to a specified pattern but all of 
them can be edited. Make sure the first point in the pattern remains at 0,0. Note that in the 
FORCAST C2NC2 node, the off position does not dither 
 
For FIFI-LS, you can load a customized map positions in some modes.  The example map 
position definition file is included in the downloaded installer. 

 
Delete AORs:  You can delete an AOR by selecting one in the summary table and click on the 
delete icon or use the menu “Edit->delete all AORs”. The latter command will clear the AOR 
summary table. You can “Undo” the deletions as long as they are not deleted by the “delete all 
AORs” command.	
  

6.8. Visualize AOR 

To visualize an AOR: 
1. Select an AOR from the summary table.   
2. Select a background image from one of the archives available from the menu “Images->xxx” 

(2MASS and MSX images are good choices for testing).   Wise catalog is added starting 
cycle 3 provided by IPAC. 
• If you want to use the haro3 fits file image as background, click on “Images->FITS File 

Image…” and then select haro3.fits. 
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• Select overlays:  After you select a background image, the image will be presented in an 

overlay window.  Use the menu “Overlays->Current AOR…” to visualize your AOR on 
the background.  Overlays for non-sidereal objects are not supported at this time. 

  
 
The image manipulation and overlay icons will appear on the left-hand side of Spot whenever 
you display images.  Click on the icons to activate them.  The magnifying glass icons are for 
zooming your images in or out. This icon  zooms in the current image, and this one  zooms 
out.  These icons,  and , apply the zoom to all the images stacked in the active frame (if 
you have only one image per frame, the ALL buttons will not be active). The crosshair icon  
centers the current target in the middle of the current image frame.  
 
 

 
 
In addition, a number of overlay options are now available from this tool bar: 
 

   overlays the current fixed target position on an image; 
     draws a coordinate grid on the image; 

   extracts a flux slice between two points on the image;  
   computes statistics in either a circular or rectangular area on the image;   
   crops the image;   
   allows you to determine the distance between two points on an image;   
   allows you to add marks on an image and create your own catalog;  
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   provides a pulldown menu from which you can select other images to overlay on the 
current image. 

 
To see the effects of changes made to an open AOR, click the “Apply” button. The overlay 
will be refreshed with your latest modifications to the AOR. 
 
Below is an example showing a FORCAST TPC in Nod Match Chop, and with a chop throw 
of 100 arcsec, chop angle 45 (no dither). 
 
 

 
 

 
Animate the sequence of the overlays:  Click on the control window the icon that looks like 
a table.  The Overlay control window will appear that displays all the position of this AOR. 
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Show or hide beams:  If you want to only see a specific beam, for example only the A beam in a 
FORCAST imaging sequence, click on the icon that has the cross inside a circle on the overlay 
control panel.  Select the beams you want to see and de-select the ones you want to hide.  
 

 
 
 

6.9. Save and Upload AORs 

Use the File->save to save the AORs to local disk and upload to the SOFIA DCS.  If the total 
duration exceeds the awarded time, SSpot will issue a warning that you must confirm.  You can 
see the total duration and awarded time on the bottom of the AORs summary table.  A pop-up 
window will appear indicating that the AORs have been successfully uploaded. 
 

6.10. Help Information 

You can click on question mark in any window bring up a help dialog.  Additional information 
on how to use any science instrument and mode are provided by the SOFIA science team, Refer 
to the “Observer’s Handbook” provided for each cycle.://www.sofia.usra.edu 
 
 

7. BUG REPORTS AND FEATURE REQUESTS 
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All feature requests and bug reports should be sent to:  
	
  
sofia_help@sofia.usra.edu 
 
In your bug report, please describe as much details as possible so we can reproduce the bug, 
including (if applicable): 
• Proposal ID, and AOR ID; 
• *.aor file that you saved;  
• actions that led to the error.  
• operating systems and version, such as Mac 10.6, windows 7, etc. 
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APPENDIX A. SAMPLE AORS 

 The file “sample_aors.aor” (included in the installed folder) includes 6 AOTs with an 
array of modes and configurations. A few overlays are included here for reference: 
 
01_0432_2,  FORCAST Imaging, C2NC2 
Overlay of 01_0432_2. When the chop throw is > 292 arcsec, you must specify the range for the 
chopping secondary. The specified min and max ranges are drawn as two lines. 
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01_0432_3,  FLITECAM Imaging, stare with dither 
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01_0432_10,  GREAT 4-point Raster Map with Beam Switching 
Chop throw 90 arcsec, chop angle 60 deg, step size 40 arcsec, number of steps is 2 in lat and lon,  
filter L1a, repeat 5. 
 

  
  


